If Image is Incorrect Size When Importing From Google Earth

Frequently asked questions - and answers!
Post Reply
User avatar
jovivier
Site Admin
Posts: 619
Joined: Thu Mar 12, 2009 2:57 pm
Company: LVL
City / Town: Blenheim
Location: Lincoln, New Zealand
Contact:

If Image is Incorrect Size When Importing From Google Earth

Post by jovivier »

For Version 17 and older.
If the new Import from Google Earth function brings in the images at a larger scale than expected this is related to the text size set to greater than 100% in Control Panel | Display. Another symptom of this is the imported image does not contain the entire contents of the selected area.

To overcome this scaling:-
1) Browse to the installed Irricad folder, commonly located in C:\Program Files (x86)\AEI Software\Irricad Pro 14.

2) Locate the IrricadGEImport executable and right-click on it. Select Properties and then select the “Compatibility” tab.

3) Disable the “Disable Display Scaling in High DPI Settings” and click Apply.
DisableScalingnew.png
DisableScalingnew.png (34.62 KiB) Viewed 6550 times
If, for some other reason, “Disable display scaling on high DPI settings” needs to remain enabled on the IrricadGEImport.exe or the Winicad.exe open the IrricadGEImport.ini file in Notepad and find the entry “DpiScale=” and enter the required scaling. For example, for 125% text size enter 1.25, for 150% text size enter 1.5, for 200% text size enter 2.0. In countries that use a comma separator rather than a point separator use 1,25 etc.

In some circumstances the issue may persist even when “Disable display scaling on high DPI settings” in the compatibility dialog is unchecked. Then enter the “DpiScale=” into the IrricadGEImport.ini as described above.

Also note that in Windows 8.1 and Windows 10 when the display text size is greater than 125% you should enter the DPIScale setting into the VCADD.ini file also located in the installed Irricad folder. See the post “Rubberbanding is Offset from Pipes / Circular Cursor Incorrect” for steps on how to correct (http://www.irricad.com/phpbb3/viewtopic.php?f=17&t=460).


This is no longer required in Version 18. If you are running Version 18 first check that you are running V18.05. If you are running 18.05 then logout or restart for the new DPI setting to be used seamlessly in IRRICAD. If you are not running V18.05 download from https://www.irricad.com/download/versio ... a90f45666e . Note that when patching 18.03 or 18.04 you will just see a “wait while 18.05 configures the system…” message. This will be very quick and V18.05 will be installed seamlessly.

Post Reply