Autocad file importing in Versions pre v10.5

FAQs for older versions of Irricad.
Post Reply
User avatar
jovivier
Site Admin
Posts: 548
Joined: Thu Mar 12, 2009 2:57 pm
Company: LVL
City / Town: Blenheim
Location: Lincoln, New Zealand
Contact:

Autocad file importing in Versions pre v10.5

Post by jovivier » Mon Nov 22, 2010 3:31 pm

The current version of IRRICAD can import up to Autocad 2013 files and ignores the layouts contained in the file, therefore importing easily and without issue.

However in older versions of IRRICAD, IRRICAD may stop responding when importing an AutoCAD file.

One reason that IRRICAD may stop responding when importing an AutoCAD file is that the AutoCad file may contain layouts, i.e., paper spaces. Normally when this is the problem a prompt offering to save the model space will be displayed. Once this model space is saved, IRRICAD then stops responding. The options for getting the drawing into IRRICAD at this stage are:

1. Terminate the Irricad application:
a. CTRL+ALT+DEL
b. Task Manger
c. Applications Tab
d. Highlight Design Name.des - IRRICAD
e. Right-click and choose "End Task"
f. Restart Irricad and import the saved model space .vcd file. Please note that the filename of the resulting .vcd file will be the same as the AutoCAD file followed by '-model.vcd'.

2. Delete all the layouts in AutoCad. There are various ways to do this:

A. Deleting the Layout Tabs
a. Open the design in AutoCad.
b. With the Model tab as the focus (i.e., clicking the Model tab so that the top window is this tab), right-click on the Layout tab.
c. The layouts can be deleted one by one or all at once. To delete the layouts all at once, 'Select all layouts'.
d. With the Model tab as the focus, right-click on the Layout tab again.
e. Delete.
f. Save the file as a different name 'File | Save As' (so that you retain the original file) and then import it into IRRICAD.

B. Selecting objects to save to a DXF file.
a. Open the design in AutoCad and ensure that the Model tab is the front tab.
b. Turn all the layers on by "Express | Layers | Turn all layers on" or manually for each layer.
c. View | Zoom all.
d. File | Save As.
e. Change the 'Save as type' to Release 14.
f. Options | DXF Options tab.
g. Check 'Select objects'.
h. OK | Save.
i. Click on the top right of the screen and then the bottom left to select all the objects.
j. Check the file name and location, then press the return key.

The current version of IRRICAD can import up to Autocad 2009 files and ignores the layouts contained in the file, therefore importing without freezing.

Post Reply