Irricad Standalone

IRRICAD Standalone - Full Install and Upgrade

Read more about the bug fixes and additions.

A code change to the IRRICAD dongle is required in order to run IRRICAD v19 - contact your distributor. If you have NOT purchased, or are NOT eligible for an upgrade to v19 DO NOT download and install this upgrade. Save the file to your hard disk.  To install double-click on the exe file in Windows Explorer. A connection to the internet is required during the installation process to register VisualCADD V8 (used in IRRICAD).  Please read this guide for more detailed installation instructions. To upgrade an existing installation of IRRICAD version 12, 13, 14, 15, 16, 17 or 18 select the "Yes, Remove Older Versions" option in the installation wizard.  For older versions or new installations select the "No, install side by side with other versions" option.

This full installation includes the 19.12 patch.

 

A code change to the IRRICAD dongle is required in order to run IRRICAD v18 - contact your distributor. If you have NOT purchased, or are NOT eligible for an upgrade to v18 DO NOT download and install this upgrade. Save the file to your hard disk.  To install double-click on the exe file in Windows Explorer. A connection to the internet is required during the installation process to register VisualCADD V8 (used in IRRICAD).  Please read this guide for more detailed installation instructions. To upgrade an existing installation of IRRICAD version 12, 13, 14, 15, 16 or 17 select the "Yes, Remove Older Versions" option in the installation wizard.  For older versions or new installations select the "No, install side by side with other versions" option.

This full installation includes the 18.06 patch. This option can also be used for silent installs.

Older Patches

This patch applies to IRRICAD v17 only, if you wish to upgrade from any older IRRICAD versions, please contact your IRRICAD distributor. This patches from 17.02 to 17.03.

Download the above file and save it to your hard-drive.  Double-click on the file to run it, IRRICAD will self-install the patch.

This patch applies to IRRICAD v16 only, if you wish to upgrade from any older IRRICAD versions, please contact your IRRICAD distributor. This patches from 16.04 to 16.06. Download the above file. IRRICAD will self-install the patch.

This patch applies to IRRICAD v15 only. This patches IRRICAD 15.08 to 15.16 and lease versions 15.0.9 to 15.1.7. Download the above file. IRRICAD will self-install the patch.